[Issue] New pickups are not created in Karrot

We have had a few issues with Karrot recently:

  1. New recurring pickups are not created.
    When we try to add new recurring pickup, a server error appears and nothing is added.
  2. New pickups for future dates in existing recurring pickups do not appear
    It seems new pickups stopped appearing last Thursday.
  3. There are no pickups when I check on Karrot Android app.
1 Like

Thanks for the report!

I deployed a new version last week where we renamed “pickups” to “activities”, but only in the code and the API (so users still see the word “pickup”). I suspect this change is responsible for your issues, I can look into it later today.

Also, if you’re doing things on the app you’ll need to update it to the latest version. I assumed only some of the errors were on the app?

@mzpawlowski that should have been fixed now, and new pickup dates for the recurring pickups should be generated.

The error was indeed related to my change, but about how I deployed it, it was an unusual deployment with some fiddly details that I didn’t quite get right! (I won’t bore you with the technical details).

Let me know if anything still looks odd… (and do make sure to upgrade to latest version of karrot app).

Thanks!

Thank you! Web Karrot looks fine now. I need to update app yet.

1 Like

Hi! A few of us in Solikyl Gothenburg have experienced similar issues. Last Monday the new, reocurring pick-up for one of our stores didn’t show up on time. However, it showed up later that night or early Tuesday morning.

The same store has another reoccuring pickup, on Thursdays, and there was no problem with the automatic publishing of a new pickup last Thursday. However, there was a problem again tonight, Monday, when strangely enough, some people saw the new pick-up published as usual at 18.00, while a few of us didn’t see it until around 18.30.

Since there is only one spot for each pick-up, and several people would like to get it, this issue causes a lot of frustration. Do you know what the problem is? I’ve checked under “Manage pick-ups” and don’t notice anything wrong, but evidently something is.

P.S. I only use the web version and in Chrome; I don’t know what the others use, but I can find out if needed.

Thanks for the report @Andrea!

I think it’s not the same issue, as for the first issue there was a clear error happening on the server which I could observe easily, and that’s not the case now.

If some people saw the pickup correctly that at least means it was created OK, but if not everybody saw it maybe the notification/update was not pushed out to them? Can you explain what you mean with “a few of us didn’t see it”, how do you “see it”? Do you mean you leave the page open and wait for it to reload? Or you load the whole page? And is it checking the little “bell” notifications? Or the pickup page?

If we can’t work it out, maybe I can join the group and you tell me if it happens again, which might give a better clue :slight_smile: